Single branch specified, using that and the previous one: remotes/brancher/net-next-2025-03-04--12-00 (v6.14-rc4-1061-ge03ed5e96ed8) remotes/brancher/net-next-2025-03-04--15-00 (v6.14-rc4-1228-g6a6231bbb5d7) ==== BASE DIFF ==== .../devicetree/bindings/net/airoha,en7581-eth.yaml | 10 + .../devicetree/bindings/net/airoha,en7581-npu.yaml | 84 ++ Documentation/networking/netconsole.rst | 28 + drivers/net/dsa/mt7530.c | 5 + drivers/net/dsa/mt7530.h | 4 + drivers/net/ethernet/Kconfig | 2 + drivers/net/ethernet/Makefile | 1 + drivers/net/ethernet/airoha/Kconfig | 27 + drivers/net/ethernet/airoha/Makefile | 9 + .../net/ethernet/{mediatek => airoha}/airoha_eth.c | 1277 +++++--------------- drivers/net/ethernet/airoha/airoha_eth.h | 551 +++++++++ drivers/net/ethernet/airoha/airoha_npu.c | 520 ++++++++ drivers/net/ethernet/airoha/airoha_npu.h | 34 + drivers/net/ethernet/airoha/airoha_ppe.c | 910 ++++++++++++++ drivers/net/ethernet/airoha/airoha_ppe_debugfs.c | 181 +++ drivers/net/ethernet/airoha/airoha_regs.h | 798 ++++++++++++ drivers/net/ethernet/hisilicon/hibmcge/Makefile | 2 +- .../net/ethernet/hisilicon/hibmcge/hbg_common.h | 122 ++ .../net/ethernet/hisilicon/hibmcge/hbg_debugfs.c | 7 +- .../net/ethernet/hisilicon/hibmcge/hbg_diagnose.c | 348 ++++++ .../net/ethernet/hisilicon/hibmcge/hbg_diagnose.h | 11 + drivers/net/ethernet/hisilicon/hibmcge/hbg_err.c | 58 + drivers/net/ethernet/hisilicon/hibmcge/hbg_err.h | 1 + .../net/ethernet/hisilicon/hibmcge/hbg_ethtool.c | 298 +++++ .../net/ethernet/hisilicon/hibmcge/hbg_ethtool.h | 5 + drivers/net/ethernet/hisilicon/hibmcge/hbg_hw.c | 10 + drivers/net/ethernet/hisilicon/hibmcge/hbg_irq.c | 55 +- drivers/net/ethernet/hisilicon/hibmcge/hbg_main.c | 103 ++ drivers/net/ethernet/hisilicon/hibmcge/hbg_mdio.c | 22 + drivers/net/ethernet/hisilicon/hibmcge/hbg_mdio.h | 2 + drivers/net/ethernet/hisilicon/hibmcge/hbg_reg.h | 105 ++ drivers/net/ethernet/hisilicon/hibmcge/hbg_txrx.c | 181 ++- drivers/net/ethernet/mediatek/Kconfig | 8 - drivers/net/ethernet/mediatek/Makefile | 1 - drivers/net/netconsole.c | 95 +- .../selftests/drivers/net/netcons_sysdata.sh | 51 +- 36 files changed, 4879 insertions(+), 1047 deletions(-) ==== COMMIT DIFF ==== diff --git a/tmp/tmp.Ga5M6yaOSh b/tmp/tmp.cHzDCnkVOR index 3f84f9b8913c..0e164dd1651e 100644 --- a/tmp/tmp.Ga5M6yaOSh +++ b/tmp/tmp.cHzDCnkVOR @@ -3,13 +3,30 @@ selftests: net: enable profiling tc_action dbg profile patch forwarding: set timeout to 3 hours -ice: fix using untrusted value of pkt_len in ice_vc_fdir_parse_raw() -ice: fix input validation for virtchnl BW -ice: validate queue quanta parameters to prevent OOB access -ice: stop truncating queue ids when checking -virtchnl: make proto and filter action count unsigned +net: airoha: Fix lan4 support in airoha_qdma_get_gdm_port() +sched: address a potential NULL pointer dereference in the GRED scheduler. +inet: fix lwtunnel_valid_encap_type() lock imbalance +Merge tag 'wireless-next-2025-03-04-v2' of https://git.kernel.org/pub/scm/linux/kernel/git/wireless/wireless-next +Merge tag 'wireless-2025-03-04' of https://git.kernel.org/pub/scm/linux/kernel/git/wireless/wireless +net/smc: use the correct ndev to find pnetid by pnetid table +ieee802154: ca8210: Switch to using gpiod API +ieee802154: ca8210: Get platform data via dev_get_platdata() +ieee802154: ca8210: Use proper setter and getters for bitwise types +net: stmmac: simplify phylink_suspend() and phylink_resume() calls net: ti: icss-iep: Add phase offset configuration for perout signal net: ti: icss-iep: Add pwidth configuration for perout signal +dt-bindings: net: pse-pd: ti,tps23881: Add interrupt description +net: pse-pd: tps23881: Add support for static port priority feature +dt-bindings: net: pse-pd: microchip,pd692x0: Add manager regulator supply +net: pse-pd: pd692x0: Add support for controller and manager power supplies +net: pse-pd: pd692x0: Add support for PSE PI priority feature +net: ethtool: Add PSE new budget evaluation strategy support feature +net: pse-pd: Add support for budget evaluation strategies +net: ethtool: Add support for new power domains index description +net: pse-pd: Add support for PSE power domains +net: pse-pd: tps23881: Add support for PSE events and interrupts +net: pse-pd: Add support for reporting events +net: ethtool: Add support for ethnl_info_init_ntf helper function net: dsa: mt7530: Fix traffic flooding for MMIO devices net/mlx5: handle errors in mlx5_chains_create_table() MAINTAINERS: add new file ntmp.h to ENETC driver @@ -117,33 +134,151 @@ mptcp: pm: in-kernel: avoid access entry without lock selftests: mptcp: add a test for mptcp_diag_dump_one selftests: mptcp: Add a tool to get specific msk_info ppp: Fix KMSAN uninit-value warning with bpf -netconsole: selftest: add task name append testing -netconsole: docs: document the task name feature -netconsole: add task name to extra data fields -netconsole: add configfs controls for taskname sysdata feature -netconsole: add taskname to extradata entry count -netconsole: refactor CPU number formatting into separate function -netconsole: Make boolean comparison consistent -netconsole: prefix CPU_NR sysdata feature with SYSDATA_ -net: hibmcge: Add support for ioctl -net: hibmcge: Add support for BMC diagnose feature -net: hibmcge: Add support for mac link exception handling feature -net: hibmcge: Add support for abnormal irq handling feature -net: hibmcge: Add support for checksum offload -net: hibmcge: Add support for dump statistics -net: airoha: Introduce PPE debugfs support -net: airoha: Add loopback support for GDM2 -net: airoha: Introduce flowtable offload support -net: airoha: Introduce Airoha NPU support -dt-bindings: net: airoha: Add airoha,npu phandle property -dt-bindings: net: airoha: Add the NPU node for EN7581 SoC -net: airoha: Rename airoha_set_gdm_port_fwd_cfg() in airoha_set_vip_for_gdm_port() -net: airoha: Move REG_GDM_FWD_CFG() initialization in airoha_dev_init() -net: airoha: Enable support for multiple net_devices -net: dsa: mt7530: Enable Rx sptag for EN7581 SoC -net: airoha: Move DSA tag in DMA descriptor -net: airoha: Move register definitions in airoha_regs.h -net: airoha: Move reg/write utility routines in airoha_eth.h -net: airoha: Move definitions in airoha_eth.h -net: airoha: Move airoha_eth driver in a dedicated folder bnx2: Fix unused data compilation warning +wifi: iwlwifi: remove mld/roc.c +wifi: nl80211: disable multi-link reconfiguration +wifi: cfg80211: regulatory: improve invalid hints checking +wifi: mac80211: refactor populating mesh related fields in sinfo +wifi: cfg80211: reorg sinfo structure elements for mesh +wifi: iwlwifi: Fix spelling mistake "Increate" -> "Increase" +wifi: iwlwifi: add Debug Host Command APIs +wifi: iwlwifi: add IWL_MAX_NUM_IGTKS macro +wifi: iwlwifi: add OMI bandwidth reduction APIs +wifi: iwlwifi: remove mvm prefix from iwl_mvm_d3_end_notif +wifi: iwlwifi: remember if the UATS table was read successfully +wifi: iwlwifi: export iwl_get_lari_config_bitmap +wifi: iwlwifi: add support for external 32 KHz clock +wifi: iwlwifi: mld: add a debug level for EHT prints +wifi: iwlwifi: mld: add a debug level for PTP prints +wifi: iwlwifi: remove mvm prefix from iwl_mvm_esr_mode_notif +wifi: iwlwifi: use 0xff instead of 0xffffffff for invalid +wifi: iwlwifi: location api cleanup +wifi: cfg80211: expose update timestamp to drivers +wifi: mac80211: add ieee80211_iter_chan_contexts_mtx +wifi: mac80211: fix integer overflow in hwmp_route_info_get() +wifi: mac80211: Fix possible integer promotion issue +wifi: cfg80211: convert timeouts to secs_to_jiffies() +wifi: mac80211: Add counter for all monitor interfaces +wifi: iwlegacy: don't warn for unused variables with DEBUG_FS=n +wifi: brcmfmac: keep power during suspend if board requires it +wifi: mac80211: Fix sparse warning for monitor_sdata +wifi: mac80211: fix vendor-specific inheritance +wifi: mac80211: fix MLE non-inheritance parsing +Merge tag 'rtw-next-2025-02-10-v2' of https://github.com/pkshih/rtw +wifi: iwlwifi: Fix A-MSDU TSO preparation +wifi: iwlwifi: Free pages allocated when failing to build A-MSDU +wifi: iwlwifi: limit printed string from FW file +wifi: iwlwifi: mvm: use the right version of the rate API +wifi: iwlwifi: mvm: don't try to talk to a dead firmware +wifi: iwlwifi: mvm: don't dump the firmware state upon RFKILL while suspend +wifi: iwlwifi: mvm: clean up ROC on failure +wifi: iwlwifi: fw: avoid using an uninitialized variable +wifi: iwlwifi: fw: allocate chained SG tables for dump +wifi: mac80211: remove debugfs dir for virtual monitor +wifi: mac80211: Cleanup sta TXQs on flush +wifi: nl80211: reject cooked mode if it is set along with other flags +wifi: iwlwifi: implement dump region split +wifi: iwlwifi: add twt operation cmd +wifi: iwlwifi: use correct IMR dump variable +wifi: iwlwifi: support ROC version 6 +wifi: iwlwifi: clarify the meaning of IWL_INIT_PHY +wifi: iwlwifi: properly set the names for SC devices +wifi: iwlwifi: make no_160 more generic +wifi: iwlwifi: be less aggressive with re-probe +wifi: iwlwifi: fw: make iwl_send_dbg_dump_complete_cmd() static +wifi: iwlwifi: mvm: Indicate support link reconfiguration +wifi: iwlwifi: Indicate support for EPCS +wifi: iwlwifi: cfg: separate 22000/BZ family HT params +wifi: iwlwifi: enable 320 MHz on slow PCIe links +wifi: iwlwifi: don't warn during reprobe +wifi: iwlwifi: Unify TAS block list handling in regulatory.c +wifi: iwlwifi: mvm: rename and move iwl_mvm_eval_dsm_rfi() to iwl_rfi_is_enabled_in_bios() +wifi: b43: Replace outdated firmware URL +wifi: mac80211: rework the Tx of the deauth in ieee80211_set_disassoc() +wifi: mac80211: ensure sdata->work is canceled before initialized. +wifi: mac80211: enable removing assoc link +wifi: mac80211: aggregation: remove deflink accesses for MLO +wifi: mac80211: always send max agg subframe num in strict mode +wifi: mac80211: don't unconditionally call drv_mgd_complete_tx() +wifi: mac80211: remove misplaced drv_mgd_complete_tx() call +wifi: mac80211: set ieee80211_prep_tx_info::link_id upon Auth Rx +wifi: mac80211: tests: add tests for ieee80211_determine_chan_mode +wifi: mac80211: add HT and VHT basic set verification +wifi: mac80211_hwsim: enable strict mode +wifi: mac80211: add strict mode disabling workarounds +wifi: mac80211: Add processing of TTLM teardown frame +wifi: ieee80211: Add missing EHT MAC capabilities +wifi: mac80211: Add support for EPCS configuration +wifi: mac80211: Refactor ieee80211_sta_wmm_params() +wifi: cfg80211: Fix trace print for removed links +wifi: qtnfmac: Avoid multiple -Wflex-array-member-not-at-end warnings +wifi: mac80211: Drop cooked monitor support +wifi: nl80211/cfg80211: Stop supporting cooked monitor +wifi: mwifiex: Remove unused mwifiex_uap_del_sta_data +wifi: ipw2x00: Fix spelling mistake "stablization" -> "stabilization" +wifi: iwlwifi: remove the mvm prefix from iwl_mvm_aux_sta_cmd +wifi: iwlwifi: remove the version number from iwl_dts_measurement_notif_v2 +wifi: iwlwifi: remove the mvm prefix from iwl_mvm_ctdp_cmd +net: rfkill: gpio: allow booting in blocked state +dt-bindings: net: rfkill-gpio: enable booting in blocked state +wifi: iwlwifi: Remove old device data +wifi: iwlwifi: Remove unused iwl_bz_name +wifi: iwlwifi: mvm: Remove unused iwl_mvm_ftm_add_pasn_sta +wifi: iwlwifi: mvm: Remove unused iwl_mvm_ftm_*_add_pasn_sta functions +wifi: iwlwifi: mvm: Remove unused iwl_mvm_rx_missed_vap_notif +wifi: iwlwifi: dvm: Remove unused iwl_rx_ant_restriction +wifi: rtw89: debugfs depends on CFG80211's one +wifi: rtlwifi: rtl8192de: Fix typos of debug message of phy setting +wifi: rtw88: Fix rtw_update_sta_info() for RTL8814AU +wifi: rtw88: Extend TX power stuff for 3-4 spatial streams +wifi: rtw88: Rename RTW_RATE_SECTION_MAX to RTW_RATE_SECTION_NUM +wifi: rtw88: Constify some more structs and arrays +wifi: rtw88: Extend rtw_fw_send_ra_info() for RTL8814AU +wifi: rtw88: Extend rf_base_addr and rf_sipi_addr for RTL8814AU +wifi: rtw88: Extend struct rtw_pwr_track_tbl for RTL8814AU +wifi: rtw88: Fix download_firmware_validate() for RTL8814AU +wifi: rtw88: Fix __rtw_download_firmware() for RTL8814AU +wifi: rtw88: Fix a typo of debug message in rtw8723d_iqk_check_tx_failed() +wifi: rtw89: regd: avoid using BITMAP_FROM_U64() to assign function bitmap +wifi: rtw89: coex: Update Wi-Fi/Bluetooth coexistence version to 7.0.3 +wifi: rtw89: coex: To avoid TWS serials A2DP lag, adjust slot arrangement +wifi: rtw89: coex: Assign value over than 0 to avoid firmware timer hang +wifi: rtw89: fw: validate multi-firmware header before getting its size +wifi: rtw89: fw: validate multi-firmware header before accessing +wifi: rtw89: ps: update H2C command with more info for PS +wifi: rtw89: call power_on ahead before selecting firmware +wifi: rtl8xxxu: retry firmware download on error +wifi: rtw88: Don't use static local variable in rtw8821c_set_tx_power_index_by_rate +wifi: rtw88: Don't use static local variable in rtw8822b_set_tx_power_index_by_rate +wifi: rtl8xxxu: Enable AP mode for RTL8192CU (RTL8188CUS) +wifi: rtw89: pci: not assert wiphy_lock to free early_h2c for PCI probe/remove +wifi: rtw89: remove definition of driver mutex +wifi: rtw89: manual cosmetic along lockdep_assert_wiphy() +wifi: rtw89: remove consumers of driver mutex +wifi: rtw89: debugfs: use debugfs_short_fops +wifi: rtw89: debugfs: use wiphy_locked_debugfs_{read,write}() if needed +wifi: rtw89: debugfs: specify buffer size allocated by devm_kazlloc() for reading +wifi: rtw89: debugfs: implement file_ops::read/write to replace seq_file +wifi: rtw89: use wiphy_work() to replace ieee802111_work() +wifi: rtw89: add wiphy_lock() to work that isn't held wiphy_lock() yet +wifi: rtw89: cleanup unused rtwdev::roc_work +wifi: rtw89: regd: refactor init/setup flow and prototype +wifi: rtw89: regd: handle supported regulatory functions by country +wifi: rtw89: regd: support loading regd table from fw element +wifi: rtw89: phy: disable CFO track when two PHY are working simultaneously +wifi: rtw89: phy: support EDCCA log per PHY +wifi: rtw89: phy: support EDCCA per PHY +wifi: rtw89: phy: support ch_info per PHY +wifi: rtw89: phy: support DIG per PHY +wifi: rtw89: phy: support env_monitor per PHY +wifi: rtw89: phy: add PHY context array to support functions per PHY +wifi: rtw89: phy: rename to RTW89_PHY_NUM as proper naming +wifi: ipw2x00: Remove unused libipw_rx_any() +wifi: libertas: Remove unused auto deep sleep code +wifi: libertas: cmd: remove unused functions +wifi: libertas: main: remove unused functions +wifi: mwifiex: Constify struct mwifiex_if_ops +wifi: rtw89: Correct immediate cfg_len calculation for scan_offload_be +wifi: rtw89: coex: Update Wi-Fi/Bluetooth coexistence version to 7.0.2 +wifi: rtw89: coex: Separated Wi-Fi connecting event from Wi-Fi scan event +wifi: rtw89: coex: Add protect to avoid A2DP lag while Wi-Fi connecting